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What is an Acrobat Form?

An Acrobat form is a printable form which is also digitally editable. By using a PDF form, you make it
possible to author one document suitable for printing and electronic fill-out. If electronically filled out,
Acrobat can aggregate the data and export it to a format suitable for Microsoft Excel — which can
significantly eliminate manual data entry. PDF forms can also be digitally signed.

What is Adobe LiveCycle Designer?

LiveCycle Designer is the PDF form editor bundled with Acrobat. LiveCycle is heavily integrated with
Acrobat and most form actions in Acrobat are actually handled by LiveCycle. When you use Acrobat to
create a form, the actual form editing and saving are done by LiveCycle. Where applicable, this
documentation refers to LiveCycle. At some points, you may need to save your document and close
LiveCycle, and re-open the PDF in Acrobat.

What is the Difference between LiveCycle and Acrobat?

Acrobat, as a tool, focuses on collaboration, and PDF creation/optimization. LiveCycle is the form editor.
It can take regular PDFs and turn them into interactive forms. LiveCycle is a part of the Acrobat
Professional Package.

Converting from other File Types into a PDF Form

It is possible to convert an existing PDF into an Acrobat form, as well as Word and Excel files. LiveCycle
will automatically attempt to detect form fields. If you try importing a Word or Excel file, the
appropriate program will be opened and the conversion will be performed.

1. In Adobe Acrobat, click the ‘Forms’ button and click ‘Create New
Form’. E-I Farms = :_? Review & Comment
2. Onthe ‘Create a New Form’ window, click ‘Start with an
electronic document’ and click ‘Continue >'.

Create Mew Form, .,

3. The first step of the process is choosing which file to convert. Compile Returned Forms. .
Click ‘Import a file from file system’ and click ‘Browse’ to Track Forms...

choose your file. Note, change ‘Files of Type’ to choose Word or
Excel files. By default, Acrobat looks for PDFs. If you have a PDF

already open, you have the option to ‘Use the current document’.

Getting Started with Forms

4. If necessary, Acrobat will convert your document into a PDF. You can then choose to have Acrobat
detect the form fields (‘Run Auto Field Detection’) or you can insert the fields manually (‘Place
Fields by Hand’). Generally, it is best to use Auto Field Detection. Click ‘Next’.

5. Click ‘Next’ and ‘Done’. You will then be asked about Form Returning. Click ‘Add an email button’ to
have data from the finished form emailed back to you. Click ‘Add a print button’ to provide a print
button for easy access on the PDF file.



New Form Assistant

Steps

1, Getting Started

2. Document Setup
Setup: Impork Options

3. Form Return Setup

Do Mot Use Assistant

Working with Fields

What is a Field?

A field is a place on the document which is intended to receive input from a user. A field is also
something which a user can interact with. A field is denoted on the LiveCycle workspace by an orange

Form Return Setup: Adding Buttons

‘fou can use this assistant to add buttons ta your Form that Form Fillers can use to
return their Farm. You can also add buttons directly on the Farm.

[]dd an email button

Form fillers use the Email Submit button o return the Form to the specified
address,

Return email address: | net-id@uwy, edu

Add a print buttan

Form fillers use the Print button ko prink the form and return it
manually,

e ‘You can also use the Distribute Feature in LiveCycle Designer to
\\l} distribute your form to Form fillers, To use the Distribute feature, you
must have an email button on your farm.
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box with black “handles” around it for resizing.

ITINERARY FOR BUSINESS RELATED ABSENCE: (Include dates/destination/purpose)

Modifying a Field Type

To change properties of a field, right-click on the field. You can change the object type (right-click >
‘Change Object Type’) or you can view the full attributes of the field by opening the ‘Object’ panel.

Right-click, then choose ‘Palettes’ > ‘Object’.




REQUEST TO BE ABSENT FROM CAMPUS

Name of Requestor: %

CHECK ONE:
NON-BUSINESS:

=] Paste

VACATION |t b oot Del
LEAVE WITH

FLANNEDSIC  Rename Object...
BUSINESS: iChange Chiject Type »
TRAVEL WIT,

ITINERARY FOR BUSINESS Nation/purpose)

@ Bring to Front
A7 Bring Forward

Palettes 3 Layout

Account to be charged: Border
G AddtoUbrary... =
Ohject

Swpervisar Apprd  Fopt
(Siznature or cop(

Moving and Resizing Fields
To move a field, click and drag the field to the intended location. To resize a field, click one of the black
“handle” boxes and drag. If you are resizing a Text Field and wish to have multiple lines for entry, Make
sure ‘Allow Multiple Lines’ is checked in the ‘Object’ panel, under the ‘Field’ tab.

Field Types U4 Text Field v
e Text Field — Enter any text with a keyboard g;‘i’ﬁ;:’sield
¢ Numeric Field — Any number-type entry, such as a regular irc_|;?’7'5'Decimal Field
number, phone number of social security number. Al %E:ijﬁ::;ifd
e Decimal Field — Same as numeric, but with a higher decimal t::ggzt‘;:e”t Signature Field
precision. Default is unlimited. o Emai Submit Button
. . CIHTTP submit Buttan
e Password Field — Same as text, but shows asterisks (*) to dHE rint Button
protect passwords. i E:::ngxtm
e Date/Time Field — Same as Text, but can be formatted :P{(®) Radio Button
specifically for dates or times. When using a date, a calendaris . ;E;?DB::W“ e
provided for easy date entry. , Bmagered -
e Document Signature Field — Allows user of the form to attach a digital ID.
e Button, Email Submit Button, etc — generic and specialized buttons to perform specific actions.
Attach JavaScript to the buttons to manipulate the form.
e Check Box Field — Provide a Yes/No-type control. When checked, a user specifies ‘Yes’ (True).
Unchecked is ‘No’ (False).
¢ Radio Button — same as Check Box, but used for a series of choices
e Drop-down list — Provide a list of choices. Only one option shown at a time
e List Box — Same as Drop-down list, but more than one option is shown.
¢ Image Field — Allow user to attach or insert a picture into the form.
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-x|| Inserting a Field
To insert a field, drag a field from the ‘Library’. Open the ‘Standard’

Ll Library =
@Date;’Time Field 'g/"ﬁDecimaI Field

?Document SignafT=2 Drop-dawn List

Bl

3 Email Submit BUCTIHTTR Submit Button Palette to see the field types listed above.
/};E:Image %jlmage Field

#Line =1 List: B

FANumeric Field | Paper Forms Barcode Deleting a Field

EzPassword Field DPrlnt Button

To delete a field, click the field on the page. Then right-click and choose
‘Delete’, or press the Delete key on your keyboard.
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et | . =
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— The name of the field is used when aggregating data. So it is important
liobject = = that field names reflect the value the user is entering. Click the field in the

PDF, then in the ‘Object’ panel click ‘Binding’. Change the ‘Name’ of the field to an appropriate value.
Good names: EstMeals, registration_cost.

Bad names: This is a very long form name, A lot of different things, form 10.

Automatically Formatting Input
For Text, Numeric, Decimal and Date/Time fields, you can specify special formatting. If a user does not
enter information into a field using the given format, an error is displayed.

Forcing a Field to Auto-format

1. Click the field you wish to format

2. Inthe Object Panel, on the ‘Field’ tab, pull down ‘Display Pattern’. Set the display pattern to the
appropriate format.

3. Change to the ‘Value’ tab and click the checkbox next to ‘Validation pattern Message’. Enter a
message that the user will see if their input does not appropriately reflect what should be
entered. Uncheck ‘Validation Script Message’.

4. On the ‘Binding’ tab, make sure ‘Data Pattern’ is set to the same as ‘Display Pattern’ on the
‘Field’ tab.

Common Formatting Codes
e MM/DD/YYYY — force the user to input a date in two-digit month, followed by two-digit day,
followed by 4-digit year, separated by forward slashes (/).
e 999-99-9999 — Social Security numbers

Calculating a Field

Adobe LiveCycle allows you to use JavaScript and form events to automatically calculate form values.
The format of the code is somewhat related to Microsoft Excel’s formula system. You can specify
specific fields. Functions are available. Unlike Excel, you can specify calculation on actions the user takes.

Formulas are entered using the Script editor. To show the Script Editor, click the ‘Window’ menu and
choose ‘Script Editor’. You can also press CTRL + SHIFT + F5 on your keyboard.
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Form Events

When a user interacts with a PDF form, that interaction is called an event. It is possible to make the
Adobe PDF do something (such as calculate a form field, submit document information, add form fields,
show or hide parts of the PDF, etc.) it is common to add JavaScript to the ‘calculate’ event. For a
complete list and explanation of the various events in LiveCycle Designer, see the Acrobat help.

It is important to understand that events, for the most part, belong

1| calculate® w| this.rawValue = auto_exp.rawVa

initialize - . . N .
e K [[ome o view & rraviw v = to form fields. Users interact with form fields. So JavaScript must
arqexl s .
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Calculating a Total When a Field is Changed
1. Click the field you wish to display the total in
2. Make sure the default value and Display Pattern are set.
3. Onthe ‘Value’ tab of the ‘Object’ panel, set ‘Type:’ to ‘Calculated — Read Only’.
4. Inthe Script Editor, by ‘Show:’ choose ‘Calculate’. The Calculate event is what will be triggered
to re-calculate the total.
5. To the right of ‘Calculate’ enter the equation to total. For example, to enter two numeric fields

named “Field1” and “Field2” together, enter: this.rawvalue = Fieldl.rawvalue +
Field2.rawvalue;.

6. Click the green plus sign to the right of the Script Editor to accept the code.

Show: | calculate® ™| falue + meals_exp.rawValus + lodging exp.rawValue + reg exp.rawvvalus + Dther_exp.raw\!alue|; @ L

If an event (in this picture, the ‘calculate’ event) has code attached to it, you’ll see an asterisk (*) by it.

Giving Reader Users the Rights to Fill-in Forms
Once a form is created, if you want users of the free Adobe Reader to be able to edit the form, do the
following:

1. If you have not done so, save your PDF and exist LiveCycle.



Open Acrobat and open the PDF form.

In Acrobat, in the ‘Advanced’ menu, choose ‘Enable Usage Rights in Adobe Reader’.

In the window that appears, click ‘Save Now’. IMPORTANT: SAVE THE PDF AS A NEW
DOCUMENT. Distribute the new version of the PDF to the end users. Keep the original version
for editing.

Advanced  Window Help
| A sign & Certify 3
1 L.h Security L4
Security Settings. ..
Manage Trusted Identities. .

Enable Usage Rights in Adobe Reader...

Print Production 4

Receiving Data
When users press the automatically inserted ‘E-Mail’ button, the user is presented with an email with an

attached ‘XML’ file. All users need to do is click ‘Send’. The data will be sent to whoever was specified

when the PDF form was being created.

When you receive the data, save each XML file to a folder on your computer. Once you’ve received all

data, use Acrobat to convert the data to a CSV file.

1.

In Acrobat, click the ‘Forms’ menu > ‘Manage Form Data’ > ‘Merge Data Files into
Spreadsheet’.

In the ‘Export Data...” window, click ‘Add Files’. And choose the XML files which you’ve saved.
Click the ‘Export’ button.

Name and save the file.

Forms Tools Advanced ‘window Help
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Viewing an Submission

1.
2.
3.

Open the PDF for the Form you wish to view
In the ‘Forms’ menu, choose ‘Manage Form Data’ > ‘Import Data’.
Choose the XML file associated with the submission you wish to view.

The data from that submission will then be loaded into the originating form.

For Further Assistance
If you have questions about how to use these features or would like further consultation, contact the

LTC (ltc@uww.edu).


mailto:ltc@uww.edu
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