Supported Browsers and System Requirements for Using D2L

Below is a chart showing the system and software requirements for running D2L.

You can also perform a quick system check to see if your set-up meets the basic requirements. Click here to do a system check.

Show me how to check my system.

Notes:
Internet Explorer for the Mac is no longer supported
Internet Explorer 7 for Windows is not supported at this time

Safari is currently not supported

System and software requirements
Component Required Recommended
Operating System
  • Windows 98, 98SE, ME, 2000, 2003, XP
  • Mac OS X (up to 10.4)
  • Windows XP Service Pack
    2
  • Mac OS X (up to 10.4)
Video
  • SVGA Monitor (set at a minimum resolution of 800x600)
  • Resolution of 1024x768 or higher
Internet speed
  • 56K modem
  • DSL or Cable
    modem
Browser (Windows)
  • Netscape 6.2 up to and including 7.2
  • Internet Explorer 5.0.1 up to and including 6.
  • Mozilla 1.3 up to and including 1.7
  • Internet Explorer 6
Browser (Mac OS X)
  • Netscape 6.2 up to and including 7.2
  • Mozilla 1.3 to 1.7
  • Netscape 7.2
Browser (Linux) [unsupported by D2L Support]
  • Mozilla 1.3 to 1.7
  • Mozilla 1.7
Javascript Enabled Enabled
Cookies Enabled Enabled