Supported Browsers and System Requirements for Using D2L

Below is a chart showing the system and software requirements for running D2L.

You can also perform a quick system check to see if your set-up meets the basic requirements. Click here to do a system check.

System and Software Requirements

Component Required Recommended
Browser (Windows) Netscape 4.7 up to and including 7.2 Internet Explorer 5 or higher Mozilla 1.3 up to and including 1.6 Internet Explorer 6
Browser (Mac)* Netscape 4.7 up to and including 7.2
Mozilla 1.3 up to and including 1.6
Netscape 7.0 and higher
Operating System Windows 98 or higher

MacOS 9 or OS X
Windows 98 or higher

MacOS X
Video SVGA Monitor (set at a minimum resolution of 800x600) Resolution of 1024x768 or higher
Internet speed 56K modem with internet access DSL or Cable
Javascript Enabled Enabled
Cookies Enabled Enabled
Pop-Up Blocker Disabled (interferes with tools that open new browser windows) Disabled (interferes with tools that open new browser windows)

*Mac Users Note: Safari is not supported at this time. You are free to use Safari, but if problems arise, it will most likely be due to your browser choice. If you run into problems, try using Mozilla or Netscape. Internet Explorer for Mac is no longer supported.